php7 compatibility

Anthony Exeter shared this idea 22 months ago
Completed

Hello,


I would like clientexec to be compatible with php7


Kind regards,

Anthony

Best Answer
photo

PHP 7.0.x works with the latest (Clientexec 5.5) version. However, it requires ionCube Loader version 6.0.9 (as this version addresses a bug with the loader that prevents Clientexec from loading).


As of right now, but cPanel's EasyApache and CloudLinux's PHP Select do not install the latest version, so the loader will need to be loaded manually.

Comments (10)

photo
1

To my knowledge, PHP 7.0.x works fine with the latest Clientexec. ionCube doesn't support PHP 7.1, so that's out of our hands.

photo
1

Hi Matt,


Thanks for the reply.


It's not working for me - I will submit a ticket.


Kind regards,

Anthony

photo
1

PHP 7.0.x works with the latest (Clientexec 5.5) version. However, it requires ionCube Loader version 6.0.9 (as this version addresses a bug with the loader that prevents Clientexec from loading).


As of right now, but cPanel's EasyApache and CloudLinux's PHP Select do not install the latest version, so the loader will need to be loaded manually.

photo
1

Hi Matt,


I got a update from Cloudlinix yesterday that the ioncube 6.0.9 stable version was released yesterday. It was then installed on our server is is all good :)

photo
1

Anthony,


I just ran yum update and mine says 6.0.4 is the latest. How did you get 6.0.9 installed ?

photo
1

Hmm, I am using easyapache4 I'm guessing you are not that is how you are on 6.0.9

photo
1

I have contacted cPanel and they have added case EA-6187 to have EasyApache4 install ionCube Loader 6.0.9.

photo
photo
1

I don't have a problem with php 7.1 in my plesk server though.

photo
1

It also depends on the ionCube version . To use PHP 7.x you need to be using the latest ionCube version (which is 6.0.9).

photo
photo
1

We have problem with php 7.2 . Is this going to be fixed on the next release?